Ferrum IT - Co-MIT Documentation Portal - Users report general system slowness – Incident details
Get Support
Get updates
Email
SMS
Slack
Microsoft Teams
Webhook
API
Get Support
Get updates
Dark mode
All systems operational
Co-MIT Documentation Portal - Users report general system slowness
Resolved
Operational
Started about 1 month ago
Lasted 31 minutes
Updates
Resolved
February 05, 2026 at 5:49 PM
Resolved
February 05, 2026 at 5:49 PM
This incident has been resolved. Our partner has remediated the issue and put measures in place to prevent a reoccurrence.
Update
February 05, 2026 at 5:27 PM
Update
February 05, 2026 at 5:27 PM
Our partner has been engaged and is currently working on the issue.
Investigating
February 05, 2026 at 5:17 PM
Investigating
February 05, 2026 at 5:17 PM
We have engaged our vendor on this issue and are currently investigating this incident.