Ferrum IT - Direct To Tech Toll Free Number Not Receiving SMS/MMS Messages – Incident details

All systems operational

Direct To Tech Toll Free Number Not Receiving SMS/MMS Messages

Resolved
Major outage
Started 10 days agoLasted about 2 hours

Affected

Support

Operational from 10:07 PM to 11:37 PM

Phone

Operational from 10:07 PM to 11:37 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified
    Our direct to tech toll free number +1-833-330-3282 is not receiving SMS/MMS messages at this time. We have raised this issue with our carrier and are working to restore services.